Knowledge Base > Article [0079]

Update Tomcat version

Some people are concerned about the Tomcat version DualShield deployed, they want to upgrade it to its latest version. Here is the instruction.

Check your current Tomcat version

Majorly pay attention to its architecture, here it is x86.

Download a zip version of the latest Tomcat (same architecture), the latest v6x tomcat (32bit) is

Stop DualShield service.

Backup the current tomcat folder (C:\Program Files\Deepnet DualShield\tomcat) to tomcat6.0.24.

Unzip the new tomcat version to over-write the existing one. 

Delete the file tcnative-1.dll under bin folder.

From backup folder tomcat6.0.24, find the file server.xml and context.xml, which should be located under the sub-folder tomcat6.0.24\conf, copy them back to tomcat/conf folder.

Remove everything under C:\Program Files\Deepnet DualShield\tomcat\work (this step may not be necessary).

Start DualShield service.